Irish Subaru Drivers Club Forum - Powered by vBulletin

#

Page 2 of 2 FirstFirst 12
Results 21 to 37 of 37

Thread: Legacy slugish start

  1. #21
    Committe Members Ciaran WRX's Avatar
    Join Date
    Jan 2013
    Location
    Ireland
    Posts
    12,196
    Thanks
    4,846
    Thanked 4,426 Times in 2,441 Posts
    Rides
    1
    Rep Power
    61
    Fyi Varta built in same factory identical



    Sent from my SM-G935F using Tapatalk

  2. #22
    Commitee Member / ISDC Event Organizer GORDON GT SERIES II's Avatar
    Join Date
    Mar 2008
    Location
    offaly
    Posts
    7,252
    Thanks
    1,705
    Thanked 1,631 Times in 1,117 Posts
    Rides
    1
    Rep Power
    34
    City auto are actually closed now Ciaran closed the door about a month back

    Sent from my SM-G930F using Tapatalk

  3. #23
    Committe Members Ciaran WRX's Avatar
    Join Date
    Jan 2013
    Location
    Ireland
    Posts
    12,196
    Thanks
    4,846
    Thanked 4,426 Times in 2,441 Posts
    Rides
    1
    Rep Power
    61
    Quote Originally Posted by GORDON GT SERIES II View Post
    City auto are actually closed now Ciaran closed the door about a month back

    Sent from my SM-G930F using Tapatalk
    Jeazus that's mad

    Sent from my SM-G935F using Tapatalk

  4. #24
    Commitee Member / ISDC Event Organizer GORDON GT SERIES II's Avatar
    Join Date
    Mar 2008
    Location
    offaly
    Posts
    7,252
    Thanks
    1,705
    Thanked 1,631 Times in 1,117 Posts
    Rides
    1
    Rep Power
    34
    Yeah man one of the oldest factors in Dublin heard a lot of stories lads pretty much giving stuff away shame really

    Sent from my SM-G930F using Tapatalk

  5. #25
    Committe Members Ciaran WRX's Avatar
    Join Date
    Jan 2013
    Location
    Ireland
    Posts
    12,196
    Thanks
    4,846
    Thanked 4,426 Times in 2,441 Posts
    Rides
    1
    Rep Power
    61
    Quote Originally Posted by GORDON GT SERIES II View Post
    Yeah man one of the oldest factors in Dublin heard a lot of stories lads pretty much giving stuff away shame really

    Sent from my SM-G930F using Tapatalk
    There a long time alright always a shame to see

    Sent from my SM-G935F using Tapatalk

  6. #26
    Full ISDC Club Member Jarocki's Avatar
    Join Date
    Jul 2016
    Location
    Dublin
    Posts
    346
    Thanks
    18
    Thanked 135 Times in 83 Posts
    Rides
    0
    Rep Power
    4
    That is a shame alright. I actually found the battery on eurocarparts, link below for €158.90. Is that a good price? Seems expensive for a battery though never had to bu one for a car before.

    https://www.eurocarparts.com/en_ie/e...057&1&cc5_1002

    Thanks

  7. #27
    Full ISDC Club Member
    Join Date
    Sep 2015
    Location
    wexford
    Posts
    393
    Thanks
    270
    Thanked 298 Times in 148 Posts
    Rides
    0
    Rep Power
    7
    The exact same thing is happening to mine since I've had it off the road.
    Gonna get new battery and hopefully sorts it out.

  8. #28
    Full ISDC Club Member Jarocki's Avatar
    Join Date
    Jul 2016
    Location
    Dublin
    Posts
    346
    Thanks
    18
    Thanked 135 Times in 83 Posts
    Rides
    0
    Rep Power
    4
    Just found this crowd. Rang them there to see if they can order in for this price. Some difference.

    https://dexterautoparts.ie/batteries,36219,0.html

  9. #29
    Full ISDC Club Member Jarocki's Avatar
    Join Date
    Jul 2016
    Location
    Dublin
    Posts
    346
    Thanks
    18
    Thanked 135 Times in 83 Posts
    Rides
    0
    Rep Power
    4
    I picked up the bosch battery from dexter auto for €95. I installed it last night. Brought it for a small run. This morning However similar symptoms to before. The drive to work was 45 minutes. Will see how it starts after work at 4pm. If it's the same i may bring the car down to Ciaran Larkin to check it out.

  10. #30
    Full ISDC Club Member Jarocki's Avatar
    Join Date
    Jul 2016
    Location
    Dublin
    Posts
    346
    Thanks
    18
    Thanked 135 Times in 83 Posts
    Rides
    0
    Rep Power
    4
    So after changing the battery out the same symptoms are there after a day without driving. Just a slight struggle to start.

  11. #31
    Full ISDC Club Member Gary sti's Avatar
    Join Date
    Jan 2017
    Location
    Dublin
    Posts
    2,265
    Thanks
    1,734
    Thanked 1,336 Times in 801 Posts
    Rides
    0
    Rep Power
    17
    Quote Originally Posted by Jarocki View Post
    So after changing the battery out the same symptoms are there after a day without driving. Just a slight struggle to start.
    The fact that you have a new battery in if you have a volt meter battery should be 12v-12.4v with engine turned off. Turn on car with engine running a healthy alternator should read about 14v for recharging might be not be working 100% could be strain on battery. Or starter just showing a bit of age had this on other car local garage struggling to find what it was I bit the bullet put new starter in bang on perfect. But a decent garage should be able to spot it I think

    My Impreza would take a couple of turns to get going sometimes but not driven Daly if this helps

  12. #32
    Full ISDC Club Member Jarocki's Avatar
    Join Date
    Jul 2016
    Location
    Dublin
    Posts
    346
    Thanks
    18
    Thanked 135 Times in 83 Posts
    Rides
    0
    Rep Power
    4
    Yes thanks for that advise. Can is an 06 so possibly the starter. Will get the car down to Ciaran Larkin over the next few days when he is available.

  13. The Following User Says Thank You to Jarocki For This Useful Post:

    Gary sti (14-03-2018)

  14. #33
    Full ISDC Club Member Jarocki's Avatar
    Join Date
    Jul 2016
    Location
    Dublin
    Posts
    346
    Thanks
    18
    Thanked 135 Times in 83 Posts
    Rides
    0
    Rep Power
    4
    Had the car down with Ciaran and before he spends time on it. He said he is confident it will start every time and before he spends days trying to diagnose it without spending money on parts we agreed to leave it for the time being see how it goes. He did all tests and alternator reading 14V and when started battery drops to around 8 volts on start up. So possibly is the starter. Just not 100%.

  15. #34
    Full ISDC Club Member
    Join Date
    Jan 2008
    Posts
    340
    Thanks
    2
    Thanked 27 Times in 12 Posts
    Rides
    0
    Rep Power
    11
    happened to me before, had a bad connection to the crank sensor

  16. #35
    Full ISDC Club Member Jarocki's Avatar
    Join Date
    Jul 2016
    Location
    Dublin
    Posts
    346
    Thanks
    18
    Thanked 135 Times in 83 Posts
    Rides
    0
    Rep Power
    4
    That's interesting. Do you have a legacy too? How did you spot the bad connection?

  17. #36
    Full ISDC Club Member
    Join Date
    Jan 2008
    Posts
    340
    Thanks
    2
    Thanked 27 Times in 12 Posts
    Rides
    0
    Rep Power
    11
    yea have a 05 legacy , mechanic friend diagnosed it , the starter in the legacy sounds very lazy as well ,very slow to turn. mine used to turn and turn for ages and eventually fire up.

  18. #37
    Full ISDC Club Member Jarocki's Avatar
    Join Date
    Jul 2016
    Location
    Dublin
    Posts
    346
    Thanks
    18
    Thanked 135 Times in 83 Posts
    Rides
    0
    Rep Power
    4
    Yep the legacy was always a little slow to start alright. Ciaran did say the starter was drawing a little higher current than normal which would explain the lower voltage at the battery on startup.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •