PDA

View Full Version : Slight miss !!!



icemancg
12-12-2006, 23:40
hi there lads
i got my hand's on a nice 93 wrx import.. it was sitting up for a year and a half so when i 1st took it for a test drive i thought it need'd new plugs..
so two service's later still have the miss ......
it will miss if i put my foot to the floor.. if i just slowlly but my foot down it wont miss (not that slowly).. allways between 4000rpm to 5000rpm ..
it would only do it once ... between that rev range..
there is no loss of power what so ever...
the more i drive the car on the more it does it ... only when your givin it holly thow ??
never when you drive it normally ...
the problems allways been the same from day one its not getting any worce..
please say someone knows :oops:


thanks in advance

555-Scooby
13-12-2006, 00:02
could be a spark plug lead or the coil pack.

davelegacy
13-12-2006, 00:13
as said be lookin at coil packs.

GT performance
13-12-2006, 09:13
99% sure its coil packs

icemancg
13-12-2006, 13:42
looks like the coils then ...
thanks for the help by the way ...
anyone got a rough idea on price for coil pack for 93 wrx ?
and wheres the best place .....

thanks again

GT performance
13-12-2006, 14:15
there expensive have to buy them from subaru and quote chassis no. as they changed from very 1st ones with two bolts to single bolt.

George

johnny99
13-12-2006, 14:55
Has that engine not got the 2 double ended "waste spark" coils on the inlet manifold. If so, I'd say leads. Make sure it's not over boosting. Check all small hoses from the wastegate actuator to see if there perished

John

GT performance
13-12-2006, 16:21
dont think so John im almost 100% sure it has the old 2-bolt coil packs and then changed in 94-95 to single bolt coil packs both types are single packs for each cylinder with no leads.


George

icemancg
13-12-2006, 16:28
yea it does have old 2-bolt coil pack !!!.....